Craft 3 Dev Preview

Installing and Updating

Requirements #

Craft 3 has the same requirements as Craft 2, with the following exceptions:

  • PHP 5.6 or later
  • MySQL 5.5 or later
  • Intl Extension (optional) – Enables support for all locales supported by the ICU library.

Installing #

You can install a fresh copy of Craft 3 using the same installation instructions as Craft 2. The only exception is that you should upload the public/cpresources/ folder to your web root, and ensure that the folder is writable by PHP.

If you don’t have the Intl extension installed and wish to use a locale that isn’t officially translated, you will need to install its locale data file in your craft/locales/ folder.

Updating from Craft 2 #

If you have a Craft 2 site, you can update it to Craft 3 Dev Preview by following these steps:

  1. Ensure that your Craft installation is running Craft 2.6.2788 or later.
  2. Download the latest version of Craft 3 Dev Preview.
  3. Replace your site’s craft/app/ folder with the new one in the zip.
  4. Refresh your Control Panel and click the “Finish up” button.

Craft 3 Dev Preview should not be used for actual projects.