Requirements

The server requirements for Craft Commerce are the same as Craft 3.5 as well as PHP’s SOAP extension.

# PHP Package Dependencies

Craft Commerce uses the following PHP packages. Please see their documentation for any additional requirements.

# Dompdf

In strictly following Craft’s server requirements, Commerce requires a version of Dompdf that’s compatible with PHP 7.0 but results in errors with PHP 7.4.

You can resolve by updating your project’s composer.json platform requirement to PHP 7.1 or greater:





 




// ...
"config": {
  "optimize-autoloader": true,
  "platform": {
    "php": "7.1"
  }
}
// ...

Running composer update will install Dompdf 0.8.4+.